Debian DSA-2837-1 : openssl - programming error

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Debian host is missing a security-related update.

Description :

Anton Johansson discovered that an invalid TLS handshake package could
crash OpenSSL with a NULL pointer dereference.

The oldstable distribution (squeeze) is not affected.

See also :

http://www.debian.org/security/2014/dsa-2837

Solution :

Upgrade the openssl packages.

For the stable distribution (wheezy), this problem has been fixed in
version 1.0.1e-2+deb7u3.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)

Family: Debian Local Security Checks

Nessus Plugin ID: 71849 ()

Bugtraq ID:

CVE ID: CVE-2013-4353