Mac OS X : Safari < 6.1.1 / 7.0.1 Multiple Vulnerabilities

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by several
vulnerabilities.

Description :

The version of Safari installed on the remote Mac OS X host is prior to
6.1.1 or 7.0.1. It is, therefore, potentially affected by several
issues :

- A use-after-free error exists related to 'inline-block'
rendering. (CVE-2013-2909)

- Multiple, unspecified memory corruption vulnerabilities
exist in WebKit that could lead to unexpected program
termination or arbitrary code execution. (CVE-2013-5195,
CVE-2013-5196, CVE-2013-5197, CVE-2013-5198,
CVE-2013-5199, CVE-2013-5225, CVE-2013-5228)

- Multiple information disclosure vulnerabilities exist
due to an origin-validation error in which user
information is auto-filled into a sub-frame from a
different domain. (CVE-2013-5227)

See also :

http://www.zerodayinitiative.com/advisories/ZDI-13-286/
http://support.apple.com/kb/HT6082
http://support.apple.com/kb/HT6084
http://www.securityfocus.com/archive/1/530366/30/0/threaded
http://www.securityfocus.com/archive/1/530369/30/0/threaded

Solution :

For Mac OS X 10.9, upgrade to 10.9.1, which includes Safari 7.0.1.
Otherwise, upgrade to Safari 6.1.1 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false