Google Chrome < 31.0.1650.48 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2013-2015 Tenable Network Security, Inc.

Synopsis :

The remote Mac OS X host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The version of Google Chrome installed on the remote Mac OS X host is a
version prior to 31.0.1650.48. It is, therefore, affected by multiple
vulnerabilities :

- Various, unspecified errors exist. (CVE-2013-2931)

- Use-after-free errors exist related to speech input
elements, media elements, 'id' attribute strings, DOM
ranges, and libjingle. (CVE-2013-6621, CVE-2013-6622,
CVE-2013-6624, CVE-2013-6625, CVE-2013-6631)

- Out-of-bounds read errors exist in SVG and HTTP
parsing. (CVE-2013-6623, CVE-2013-6627)

- An address bar URI-spoofing vulnerability exists that is
related to interstitial warnings. (CVE-2013-6626)

- A certificate validation security bypass issue exists
during TLS renegotiation. (CVE-2013-6628)

- A memory corruption error exists in the libjpeg and
libjpeg-turbo libraries when memory is uninitialized
when decoding images with missing SOS data.

- A memory corruption error exists in the 'jdmarker.c'
source file in the libjpeg-turbo library when processing
Huffman tables. (CVE-2013-6630)

See also :

Solution :

Upgrade to Google Chrome 31.0.1650.48 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : true