Mac OS X : OS X Server < 3.0 Multiple Vulnerabilities

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote host is missing a security update for OS X Server.

Description :

The remote Mac OS X host has a version of OS X Server that is older
than 3.0. As such, it is reportedly affected by the following
vulnerabilities :

- A denial of service vulnerability exists in the
included JSON Ruby Gem, which could be abused to use
all available memory. (CVE-2013-0269)

- Multiple cross-site scripting vulnerabilities exist in
the included Ruby on Rails software. (CVE-2013-1854 /
CVE-2013-1855 / CVE-2013-1856 / CVE-2013-1857)

- A buffer overflow exists in the included FreeRADIUS
software that can be triggered when parsing the 'not
after' timestamp in a client certificate when using
TLS-based EAP methods. (CVE-2012-3547)

- A logic issue exists whereby the RADIUS service could
choose an incorrect certificate from a list of
configured certificates.

See also :

http://support.apple.com/kb/HT5999
http://lists.apple.com/archives/security-announce/2013/Oct/msg00006.html

Solution :

Upgrade to Mac OS X Server v3.0 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 70590 ()

Bugtraq ID: 55483
57899
58549
58552
58554
58555
63285

CVE ID: CVE-2012-3547
CVE-2013-0269
CVE-2013-1854
CVE-2013-1855
CVE-2013-1856
CVE-2013-1857
CVE-2013-5143