Amazon Linux AMI : axis Man-in-the-middle Vulnerability (ALAS-2013-164)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Amazon Linux AMI host is missing a security update.

Description :

Apache Axis did not verify that the server hostname matched the domain
name in the subject's Common Name (CN) or subjectAltName field in
X.509 certificates. This could allow a man-in-the-middle attacker to
spoof an SSL server if they had a certificate that was valid for any
domain name. (CVE-2012-5784)

See also :

http://www.nessus.org/u?2a8d1df0

Solution :

Run 'yum update axis' to update your system.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N)

Family: Amazon Linux Local Security Checks

Nessus Plugin ID: 69723 ()

Bugtraq ID:

CVE ID: CVE-2012-5784