Amazon Linux AMI : kernel Memory Leak Vulnerability (ALAS-2012-118)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Amazon Linux AMI host is missing a security update.

Description :

820039: CVE-2012-3430 kernel: recv{from,msg}() on an rds socket can
leak kernel memory (CVE-2012-3430)

See also :

http://www.nessus.org/u?bbc7008e

Solution :

Run 'yum update kernel' to update your system.

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:N)

Family: Amazon Linux Local Security Checks

Nessus Plugin ID: 69608 ()

Bugtraq ID:

CVE ID: CVE-2012-3430