Oracle Java JDK / JRE 5 < Update 41 Remote Code Execution (Unix)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote host contains a runtime environment that can allow code
execution.

Description :

The version of Oracle (formerly Sun) Java Runtime Environment (JRE)
5.x installed on the remote host is earlier than Update 41. It,
therefore, potentially can allow remote code execution due to the
following vulnerabilities related to the '2D' sub-component :

- An integer overflow error exists related to handling
sample model instances that could result in memory
corruption leading to arbitrary code execution.
(CVE-2013-0809)

- An unspecified error exists that could allow memory to
be overwritten and could allow the security manager to
be bypassed, thus leading to application crashes or
arbitrary code execution. (CVE-2013-1493)

Please note this issue affects client deployments only and is
exploited through untrusted 'Java Web Start' applications and
untrusted Java applets.

See also :

http://www.zerodayinitiative.com/advisories/ZDI-13-142/
http://www.zerodayinitiative.com/advisories/ZDI-13-148/
http://www.zerodayinitiative.com/advisories/ZDI-13-149/
http://www.nessus.org/u?1f2416e2
http://www.nessus.org/u?6086d976
http://www.security-explorations.com/en/SE-2012-01-status.html
http://www.oracle.com/technetwork/java/eol-135779.html

Solution :

Update to JDK / JRE 5 Update 41 or later and remove, if necessary,
any affected versions.

Note that an Extended Support contract with Oracle is needed to obtain
JDK / JRE 5 Update 41 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 65049 ()

Bugtraq ID: 58238
58296

CVE ID: CVE-2013-0809
CVE-2013-1493