Oracle Java SE Multiple Vulnerabilities (October 2010 CPU) (Unix)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Unix host contains a programming platform that is affected
by multiple vulnerabilities.

Description :

The version of Oracle (formerly Sun) Java SE or Java for Business
installed on the remote host is earlier than 6 Update 22 / 5.0 Update
26 / 1.4.2_28. Such versions are potentially affected by security
issue in the following components :

- CORBA
- Deployment
- Deployment Toolkit
- Java 2D
- Java Web Start
- JNDI
- JRE
- JSSE
- Kerberos
- Networking
- New Java Plug-in
- Sound
- Swing

See also :

http://www.nessus.org/u?bc96963b
http://www.oracle.com/technetwork/java/eol-135779.html

Solution :

Update to JDK / JRE 6 Update 22, JDK 5.0 Update 26, SDK 1.4.2_28 or
later and remove, if necessary, any affected versions.

Note that an Extended Support contract with Oracle is needed to obtain
JDK 5.0 Update 26 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 9.5
(CVSS2#E:F/RL:U/RC:C)
Public Exploit Available : true