MiniUPnP < 1.4 Multiple Vulnerabilities

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.


Synopsis :

A network service running on the remote host has multiple
vulnerabilities.

Description :

According to its banner, the version of MiniUPnP running on the remote
host is prior to 1.4. It is, therefore, affected by the following
vulnerabilities :

- An out-of-bounds read error exists in the
ProcessSSDPRequest() function in file minissdp.c that
allows an unauthenticated, remote attacker to cause a
denial of service condition via a specially crafted
M-SEARCH request. (CVE-2013-0229)

- A stack-based buffer overflow condition exists in the
ExecuteSoapAction() function in the SOAPAction handler,
due to improper validation of user-supplied input. An
unauthenticated, remote attacker can exploit this, via a
long quoted method, to cause a denial of service
condition or the execution of arbitrary code.
(CVE-2013-0230)

See also :

http://www.nessus.org/u?37da582a
https://community.rapid7.com/docs/DOC-2150
http://www.nessus.org/u?54e32505

Solution :

Upgrade to MiniUPnP version 1.4 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Gain a shell remotely

Nessus Plugin ID: 64377 ()

Bugtraq ID: 57607
57608

CVE ID: CVE-2013-0229
CVE-2013-0230

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now