GLSA-201209-19 : NUT: Arbitrary code execution

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201209-19
(NUT: Arbitrary code execution)

An error in the addchar() function in parseconf.c may cause a buffer
overflow.

Impact :

A remote attacker could send a specially crafted string to upsd,
possibly resulting in execution of arbitrary code with the privileges of
the process or a Denial of Service condition.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201209-19.xml

Solution :

All NUT users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=sys-power/nut-2.6.3'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 62361 ()

Bugtraq ID: 53743

CVE ID: CVE-2012-2944