Mac OS X Multiple Vulnerabilities (Security Update 2012-004)

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.


Synopsis :

The remote host is missing a Mac OS X update that fixes multiple
security vulnerabilities.

Description :

The remote host is running a version of Mac OS X 10.6 that does not
have Security Update 2012-004 applied. This update contains multiple
security-related fixes for the following components :

- Apache
- Data Security
- DirectoryService
- ImageIO
- International Components for Unicode
- Mail
- PHP
- QuickLook
- QuickTime
- Ruby

See also :

http://www.zerodayinitiative.com/advisories/ZDI-12-185/
http://archives.neohapsis.com/archives/fulldisclosure/2012-11/0112.html
http://support.apple.com/kb/HT5501
http://lists.apple.com/archives/security-announce/2012/Sep/msg00004.html
https://www.imperialviolet.org/2011/09/23/chromeandbeast.html
https://www.openssl.org/~bodo/tls-cbc.txt

Solution :

Install Security Update 2012-004 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true