Ubuntu 8.04 LTS / 10.04 LTS / 11.04 / 11.10 / 12.04 LTS : gnupg, gnupg2 vulnerability (USN-1570-1)

Ubuntu Security Notice (C) 2012-2013 Canonical, Inc. / NASL script (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

It was discovered that GnuPG used a short ID when downloading keys
from a keyserver, even if a long ID was requested. An attacker could
possibly use this to return a different key with a duplicate short key
id.

Solution :

Update the affected gnupg and / or gnupg2 packages.

Risk factor :

High

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 62179 ()

Bugtraq ID:

CVE ID: