Scientific Linux Security Update : glibc on SL6.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.

Synopsis :

The remote Scientific Linux host is missing one or more security

Description :

The glibc packages provide the standard C and standard math libraries
used by multiple programs on the system. Without these libraries, the
Linux system cannot function properly.

Multiple integer overflow flaws, leading to stack-based buffer
overflows, were found in glibc's functions for converting a string to
a numeric representation (strtod(), strtof(), and strtold()). If an
application used such a function on attacker controlled input, it
could cause the application to crash or, potentially, execute
arbitrary code. (CVE-2012-3480)

All users of glibc are advised to upgrade to these updated packages,
which contain a backported patch to correct these issues.

See also :

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 4.6

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 61693 ()

Bugtraq ID:

CVE ID: CVE-2012-3480