Ubuntu 10.04 LTS / 11.04 / 11.10 / 12.04 LTS : libotr vulnerability (USN-1541-1)

Ubuntu Security Notice (C) 2012-2013 Canonical, Inc. / NASL script (C) 2012-2013 Tenable Network Security, Inc.

Synopsis :

The remote Ubuntu host is missing a security-related patch.

Description :

Justin Ferguson discovered multiple heap overflows in libotr. A remote
attacker could use this to craft a malformed OTR message that could
cause a denial of service via application crash or possibly execute
arbitrary code.

Solution :

Update the affected libotr2 package.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.2
Public Exploit Available : false

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 61570 ()

Bugtraq ID: 54907

CVE ID: CVE-2012-3461