Adobe Reader < 10.1.4 / 9.5.2 Multiple Vulnerabilities (APSB12-16) (Mac OS X)

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.

Synopsis :

The version of Adobe Reader on the remote Mac OS X host is affected
by multiple vulnerabilities.

Description :

The version of Adobe Reader installed on the remote Mac OS X host is
earlier than 10.1.4 / 9.5.2. It is, therefore, potentially affected
by the following vulnerabilities :

- An unspecified stack-based buffer overflow error
exists. (CVE-2012-2049)

- An unspecified buffer overflow error exists.

- Numerous unspecified memory corruption errors exist.
(CVE-2012-2051, CVE-2012-4147, CVE-2012-4148,
CVE-2012-4149, CVE-2012-4150, CVE-2012-4151,
CVE-2012-4152, CVE-2012-4153, CVE-2012-4154,
CVE-2012-4155, CVE-2012-4156, CVE-2012-4157,
CVE-2012-4158, CVE-2012-4159, CVE-2012-4160,
CVE-2012-4161, CVE-2012-4162)

- An unspecified heap-based buffer overflow error
exists. (CVE-2012-1525)

See also :

Solution :

Upgrade to Adobe Reader 10.1.4 / 9.5.2 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.3
Public Exploit Available : true