Scientific Linux Security Update : jasper on SL6.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

JasPer is an implementation of Part 1 of the JPEG 2000 image
compression standard.

Two heap-based buffer overflow flaws were found in the way JasPer
decoded JPEG 2000 compressed image files. An attacker could create a
malicious JPEG 2000 compressed image file that, when opened, would
cause applications that use JasPer (such as Nautilus) to crash or,
potentially, execute arbitrary code. (CVE-2011-4516, CVE-2011-4517)

Users are advised to upgrade to these updated packages, which contain
a backported patch to correct these issues. All applications using the
JasPer libraries (such as Nautilus) must be restarted for the update
to take effect.

See also :

http://www.nessus.org/u?6a65cd9b

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 61203 ()

Bugtraq ID:

CVE ID: CVE-2011-4516