Scientific Linux Security Update : libvirt on SL6.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

It was found that several libvirt API calls did not honor the
read-only permission for connections. A local attacker able to
establish a read-only connection to libvirtd on a server could use
this flaw to execute commands that should be restricted to read-write
connections, possibly leading to a denial of service or privilege
escalation. (CVE-2011-1146)

Note: Previously, using rpmbuild without the '--define 'rhel 5''
option to build the libvirt source RPM could failed with a 'Failed
build dependencies' error for the device-mapper-devel package, as this
-devel sub-package may not be available. With this update, the -devel
sub-package is no longer checked by default as a dependency when
building , allowing the libvirt source RPM to build as expected.

See also :

http://www.nessus.org/u?d7a5675a

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 61002 ()

Bugtraq ID:

CVE ID: CVE-2011-1146