Scientific Linux Security Update : qspice-client on SL5.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing a security update.

Description :

The qspice-client package provides the client side of the SPICE
protocol.

A race condition was found in the way the SPICE Mozilla Firefox
plug-in and the SPICE client communicated. A local attacker could use
this flaw to trick the plug-in and the SPICE client into communicating
over an attacker-controlled socket, possibly gaining access to
authentication details, or resulting in a man-in-the-middle attack on
the SPICE connection. (CVE-2010-2792)

NOTE: Because qspice-client was originally only x86_64, there are
several dependencies for i386 going out with this errata.

See also :

http://www.nessus.org/u?f11b4d3e

Solution :

Update the affected qspice-client package.

Risk factor :

Low / CVSS Base Score : 3.3
(CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:N)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 60844 ()

Bugtraq ID:

CVE ID: CVE-2010-2792