Scientific Linux Security Update : gstreamer-plugins on SL3.x, SL4.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

An array indexing error was found in the GStreamer's QuickTime media
file format decoding plug-in. An attacker could create a
carefully-crafted QuickTime media .mov file that would cause an
application using GStreamer to crash or, potentially, execute
arbitrary code if played by a victim. (CVE-2009-0397, CVE-2009-0398)

After installing the update, all applications using GStreamer (such as
nautilus-media) must be restarted for the changes to take effect.

See also :

http://www.nessus.org/u?7d0b09c8

Solution :

Update the affected gstreamer-plugins and / or gstreamer-plugins-devel
packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 60531 ()

Bugtraq ID:

CVE ID: CVE-2009-0397
CVE-2009-0398