Scientific Linux Security Update : java (jdk 1.6.0) on SL4.x, SL5.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

The jdk in Scientific Linux 4 and 5 is being updated from 1.5.0 to
1.6.0. This update provides some security updates, as well as several
feature updates. Java code that was able to run on version 1.5.0
should be able run on the 1.6.0 version. It is recommended that you
recompiled your java code on 1.6.0, but it is not required.

NOTE1: jdk-1.6.0_10-fcs.i586.rpm has been digitally signed, but
jdk-1.6.0_10-fcs.x86_64.rpm has not been. We tried out best, but were
not able to sign it without breaking it.

See also :

http://www.nessus.org/u?48472607

Solution :

Update the affected java-1.5.0-sun-compat, java-1.6.0-sun-compat and /
or jdk packages.

Risk factor :

High

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 60501 ()

Bugtraq ID:

CVE ID: