GLSA-201206-09 : MediaWiki: Multiple vulnerabilities

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201206-09
(MediaWiki: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in mediawiki. Please
review the CVE identifiers referenced below for details.

Impact :

MediaWiki allows remote attackers to bypass authentication, to perform
imports from any wgImportSources wiki via a crafted POST request, to
conduct cross-site scripting (XSS) attacks or obtain sensitive
information, to inject arbitrary web script or HTML, to conduct
clickjacking attacks, to execute arbitrary PHP code, to inject arbitrary
web script or HTML, to bypass intended access restrictions and to obtain
sensitive information.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201206-09

Solution :

All MediaWiki users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.18.2'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true