HP SNMP Agents < 9.0.0 Multiple Vulnerabilities (HPSBMU02771 SSRT100558) (Red Hat)

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote host has an application installed that is affected by
multiple vulnerabilities.

Description :

The version of the HP SNMP Agents package installed on the remote Red
Hat Enterprise Linux host is earlier than 9.0.0 and, as such,
potentially affected by the following vulnerabilities :

- An unspecified cross-site scripting vulnerability
exists. (CVE-2012-2001)

- An unspecified URL redirection vulnerability exists.
(CVE-2012-2002)

See also :

http://www.nessus.org/u?f5adc03b
http://archives.neohapsis.com/archives/bugtraq/2012-05/0007.html

Solution :

Upgrade to HP SNMP Agents 9.0.0 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Red Hat Local Security Checks

Nessus Plugin ID: 59189 ()

Bugtraq ID: 53338
53340

CVE ID: CVE-2012-2001
CVE-2012-2002