Samba 3.x < 3.4.17 / 3.5.15 / 3.6.5 Security Bypass

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote Samba server is affected by a security bypass

Description :

According to its banner, the version of Samba 3.x running on the
remote host is earlier than 3.4.17 / 3.5.15 / 3.6.5, and as such, is
potentially affected by a security bypass vulnerability.

Authenticated users are able to modify ownership of files and
directories that the user does not own. Improper security checking
related to the Local Security Authority (LSA) remote procedure calls
(RPC) 'CreateAccount', 'OpenAccount', 'AddAccountRights' and
'RemoveAccountRights' can allow users these improper permissions.

Note that Nessus has not actually tried to exploit this issue or
otherwise determine if the patch or workaround has been applied.

See also :

Solution :

Either install the patch referenced in the project's advisory or
upgrade to 3.4.17 / 3.5.15 / 3.6.5 or later.

As a temporary workaround, set the 'enable privileges = no' parameter
in the [global] section of the smb.conf.

Risk factor :

Medium / CVSS Base Score : 6.5
CVSS Temporal Score : 5.7
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 58949 ()

Bugtraq ID: 53307

CVE ID: CVE-2012-2111