Apache 2.4.x < 2.4.2 'LD_LIBRARY_PATH' Insecure Library Loading

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by an insecure library loading

Description :

According to its banner, the version of Apache 2.4.x running on the
remote host is prior to 2.4.2. It is, therefore, potentially affected
by an insecure library loading issue.

The utility 'apachectl' can receive a zero-length directory name in
the LD_LIBRARY_PATH via the 'envvars' file. A local attacker with
access to that utility could exploit this to load a malicious Dynamic
Shared Object (DSO), leading to arbitrary code execution.

Note that Nessus did not actually test for this flaw, but instead
has relied on the version in the server's banner.

See also :


Solution :

Upgrade to Apache version 2.4.2 or later.

Risk factor :

Medium / CVSS Base Score : 6.9
CVSS Temporal Score : 5.7
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 58795 ()

Bugtraq ID: 53046

CVE ID: CVE-2012-0883