Juniper Junos MGD-CLI Arbitrary Command Execution (PSN-2011-11-418)

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote device has an arbitrary command execution vulnerability.

Description :

According to its self-reported version number, the version of Junos
running on the remote device has a command execution vulnerability. A
flaw in the logical model governing inter-process communications
between the management daemon (MGD) and the command-line interpreter
(CLI) could result in arbitrary command execution.

A local attacker could exploit this to completely compromise the
device.

See also :

http://www.nessus.org/u?82438147

Solution :

Apply the relevant Junos upgrade referenced in Juniper advisory
PSN-2011-11-418.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)

Family: Junos Local Security Checks

Nessus Plugin ID: 57636 ()

Bugtraq ID:

CVE ID: