Adobe AIR for Mac <= 3.0 Multiple Vulnerabilities (APSB11-28)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the instance of Adobe AIR installed on the
remote Mac OS X host is 3.0 or earlier. It is therefore reportedly
affected by several critical vulnerabilities :

- Several unspecified memory corruption errors
exist that could lead to code execution.
(CVE-2011-2445, CVE-2011-2451, CVE-2011-2452,
CVE-2011-2453, CVE-2011-2454, CVE-2011-2455,
CVE-2011-2459, CVE-2011-2460)

- An unspecified heap corruption error exists that could
lead to code execution. (CVE-2011-2450)

- An unspecified buffer overflow error exists that could
lead to code execution. (CVE-2011-2456)

- An unspecified stack overflow error exists that could
lead to code execution. (CVE-2011-2457)

See also :

http://www.adobe.com/support/security/bulletins/apsb11-28.html

Solution :

Upgrade to Adobe AIR version 3.1.0.4880 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true