iTunes < 10.5 Multiple Vulnerabilities (uncredentialed check)

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote host contains a multimedia application that has multiple
vulnerabilities.

Description :

The remote version of iTunes is older than 10.5. Thus, it is
reportedly affected by numerous issues in the following components :

- CoreFoundation
- ColorSync
- CoreAudio
- CoreMedia
- ImageIO
- WebKit

Note that these issues only affect iTunes on Windows.

See also :

http://www.zerodayinitiative.com/advisories/ZDI-11-303/
http://www.zerodayinitiative.com/advisories/ZDI-11-304/
http://support.apple.com/kb/HT4981
http://lists.apple.com/archives/security-announce/2011/Oct/msg00000.html

Solution :

Upgrade to iTunes 10.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true