HP Data Protector <= A.06.20 Multiple Vulnerabilities (uncredentialed check)

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has an application that is affected by
multiple vulnerabilities.

Description :

The version of HP Data Protector installed on the remote Windows host
is affected by one or more of the following vulnerabilities :

- Multiple denial of service vulnerabilities exist in the
'data protect inet' service. (CVE-2011-1514,
CVE-2011-1515)

- A buffer overflow vulnerability exists in the 'data
protector inet' service that can be exploited via
EXEC_CMD. (CVE-2011-1864)

- A buffer overflow vulnerability exists in the inet
service that could result in code execution via a
request containing crafted parameters. (CVE-2011-1865)

See also :

http://www.nessus.org/u?a1ae3e63
http://www.nessus.org/u?f5807534
http://www.nessus.org/u?0e38ce76

Solution :

1. Upgrade to Data Protector A.06.20 or later.

2. Enable encrypted control communication services on cell server and
all clients in cell.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Gain a shell remotely

Nessus Plugin ID: 55552 ()

Bugtraq ID: 48486
48488

CVE ID: CVE-2011-1514
CVE-2011-1515
CVE-2011-1864
CVE-2011-1865
CVE-2011-1866