Adobe Flash Media Server < 3.5.6 / 4.0.2 Multiple Vulnerabilities (APSB11-11)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.

Synopsis :

The remote media server is affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Media Server running on the remote host is
earlier than version 3.5.6 or 4.0.2. Such versions are potentially
affected by the following vulnerabilities :

- The server is affected by a memory corruption issue due
to a race condition in the TLS extension code provided
by the bundled version of OpenSSL. A remote attacker
may be able to exploit this vulnerability to execute
arbitrary code on the server. (CVE-2010-3864)

- The server is vulnerable to a denial of service attack
due to an unspecified error related to processing
certain XML content. (CVE-2011-0612)

See also :

Solution :

Upgrade to Flash Media Server 3.5.6 / 4.0.2 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 8.7
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 53895 ()

Bugtraq ID: 44884

CVE ID: CVE-2010-3864