iTunes < 10.2.2 Multiple Vulnerabilities (uncredentialed check)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application that has multiple
vulnerabilities.

Description :

The remote version of iTunes is older than 10.2.2. As such, it is
potentially affected by several issues :

- An integer overflow issue in the handling of nodesets
could lead to a crash or arbitrary code execution.
(CVE-2011-1290)

- A use after free issue in the handling of text nodes
could lead to a crash or arbitrary code execution.
(CVE-2011-1344)

Note that these issues only affect iTunes on Windows.

See also :

http://support.apple.com/kb/HT4609
http://lists.apple.com/archives/security-announce/2011/Apr/msg00004.html

Solution :

Upgrade to iTunes 10.2.2 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Peer-To-Peer File Sharing

Nessus Plugin ID: 53489 ()

Bugtraq ID: 46849
46822

CVE ID: CVE-2011-1290
CVE-2011-1344