Ubuntu 6.06 LTS / 8.04 LTS / 9.04 / 9.10 / 10.04 LTS : wget vulnerability (USN-982-1)

Ubuntu Security Notice (C) 2010-2013 Canonical, Inc. / NASL script (C) 2010-2013 Tenable Network Security, Inc.

Synopsis :

The remote Ubuntu host is missing a security-related patch.

Description :

It was discovered that Wget would use filenames provided by the server
when following 3xx redirects. If a user or automated system were
tricked into downloading a file from a malicious site, a remote
attacker could create the file with an arbitrary name (e.g. .wgetrc),
and possibly run arbitrary code.

Solution :

Update the affected wget package.

Risk factor :

Medium / CVSS Base Score : 6.8

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 49102 ()

Bugtraq ID:

CVE ID: CVE-2010-2252