Apache Tomcat < 6.0.16 Multiple Vulnerabilities

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat service may be affected by multiple

Description :

According to its self-reported version number, the Apache Tomcat
listening on the remote host is earlier than Tomcat 6.0.16 and, as
such, may be affected by multiple vulnerabilities.

- The remote Apache Tomcat install may be vulnerable to an
information disclosure attack via cookies. The previous
fix for CVE-2007-3385 was incomplete and did not account
for the use of quotes or '%5C' in cookie values.
(CVE-2007-3385, CVE-2007-5333)

- The default security policy in the JULI logging
component did not restrict access permissions to files.
This could be misused by untrusted web applications to
access and write arbitrary files in the context of the
Tomcat process. (CVE-2007-5342)

- A directory traversal vulnerability existed in the
Apache Tomcat webdav servlet. In some configurations
it allowed remote, authenticated users to read files
accessible to the local tomcat process. (CVE-2007-5461)

- When the native APR connector is used, it does not
properly handle an empty request to the SSL port, which
allows remote attackers to trigger handling of a
duplicate copy of one of the recent requests, as
demonstrated by using netcat to send the empty request.

- If the processing or parameters is interrupted, i.e. by
an exception, then it is possible for the parameters to
be processed as part of later request. (CVE-2008-0002)

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

See also :


Solution :

Update Apache Tomcat to version 6.0.16 or later.

Risk factor :

Medium / CVSS Base Score : 6.4
CVSS Temporal Score : 5.6
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 47577 ()

Bugtraq ID: 26070

CVE ID: CVE-2007-5333