ClamAV < 0.96.1 Multiple Vulnerabilities

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote antivirus service is affected by multiple denial of service
vulnerabilities.

Description :

According to its version, the clamd antivirus daemon on the remote
host is earlier than 0.96.1. Such versions are reportedly affected by
multiple vulnerabilities :

- An error exists within the 'cli_pdf()' function in
'libclamav/pdf.c' when processing certain PDF files.
(Bug 2016)

- An error exists within the 'parseicon()' function in
'libclamav/pe_icons.c' when processing PE icons. This
can be exploited to trigger an out-of-bounds access when
reading data and potentially cause a crash via a
specially crafted PE file. (Bug 2031)

See also :

http://www.nessus.org/u?1cd93f30
https://bugzilla.clamav.net/show_bug.cgi?id=2016
https://bugzilla.clamav.net/show_bug.cgi?id=2031

Solution :

Upgrade to ClamAV 0.96.1 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 46706 (clamav_0_96_1.nasl)

Bugtraq ID: 40317
40318

CVE ID: CVE-2010-1639
CVE-2010-1640