Ubuntu 6.06 LTS / 8.04 LTS / 8.10 / 9.04 / 9.10 : cups, cupsys vulnerabilities (USN-906-1)

Ubuntu Security Notice (C) 2010-2013 Canonical, Inc. / NASL script (C) 2010-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

It was discovered that the CUPS scheduler did not properly handle
certain network operations. A remote attacker could exploit this flaw
and cause the CUPS server to crash, resulting in a denial of service.
This issue only affected Ubuntu 8.04 LTS, 8.10, 9.04 and 9.10.
(CVE-2009-3553, CVE-2010-0302)

Ronald Volgers discovered that the CUPS lppasswd tool could be made to
load localized message strings from arbitrary files by setting an
environment variable. A local attacker could exploit this with a
format-string vulnerability leading to a root privilege escalation.
The default compiler options for Ubuntu 8.10, 9.04 and 9.10 should
reduce this vulnerability to a denial of service. (CVE-2010-0393).

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.4
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 44985 ()

Bugtraq ID: 38510

CVE ID: CVE-2009-3553
CVE-2010-0302
CVE-2010-0393