OpenSSH < 4.9 'ForceCommand' Directive Bypass

This script is Copyright (C) 2011 Tenable Network Security, Inc.


Synopsis :

The remote SSH service is affected by a security bypass
vulnerability.

Description :

According to its banner, the version of OpenSSH installed on the
remote host is earlier than 4.9. It may allow a remote, authenticated
user to bypass the 'sshd_config' 'ForceCommand' directive by modifying
the '.ssh/rc' session file.

See also :

http://www.openssh.org/txt/release-4.9

Solution :

Upgrade to OpenSSH version 4.9 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 44079 ()

Bugtraq ID: 28531

CVE ID: CVE-2008-1657