OpenSSH < 4.5 Multiple Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote SSH service is affected by multiple vulnerabilities.

Description :

According to its banner, the remote host is running a version of
OpenSSH prior to 4.5. Versions before 4.5 are affected by the
following vulnerabilities :

- A client-side NULL pointer dereference, caused by a
protocol error from a malicious server, which could
cause the client to crash. (CVE-2006-4925)

- A privilege separation vulnerability exists, which could
allow attackers to bypass authentication. The
vulnerability is caused by a design error between
privileged processes and their child processes. Note
that this particular issue is only exploitable when
other vulnerabilities are present. (CVE-2006-5794)

- An attacker that connects to the service before it has
finished creating keys could force the keys to be
recreated. This could result in a denial of service for
any processes that relies on a trust relationship with
the server. Note that this particular issue only affects
the Apple implementation of OpenSSH on Mac OS X.
(CVE-2007-0726)

See also :

http://www.openssh.org/txt/release-4.5
http://support.apple.com/kb/TA24626
http://openssh.com/security.html

Solution :

Upgrade to OpenSSH 4.5 or later.
For Mac OS X 10.3, apply Security Update 2007-003.
For Mac OS X 10.4, upgrade to 10.4.9.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 44077 ()

Bugtraq ID: 20956

CVE ID: CVE-2006-4925
CVE-2006-5794
CVE-2007-0726