OpenSSH < 1.2.3 xauth Session Highjacking

This script is Copyright (C) 2011-2012 Tenable Network Security, Inc.


Synopsis :

The remote host has an application installed that is affected by a
session highjacking vulnerability.

Description :

According to its banner, the remote host is running a version of
OpenSSH earlier than 1.2.3. Such versions are affected by a session
highjacking vulnerability. By default, ssh clients negotiate to
forward X connections by using the xauth program to place cookies in
the authorization cache of the remote machine for the user that is
logging in. It is possible for the xauth key to be read from the
user's .Xauthority file which could allow a remote attacker to control
the client's X sessions via a malicious xauth program.

See also :

http://www.openssh.org/txt/release-1.2.3p1
http://openssh.com/security.html
http://marc.info/?l=bugtraq&m=95151911210810&w=4

Solution :

Upgrade to OpenSSH 1.2.3 or later.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:U/RL:U/RC:ND)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 44067 ()

Bugtraq ID: 1006

CVE ID: CVE-2000-0217