RHEL 3 / 4 : 4Suite (RHSA-2009:1572)

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

An updated 4Suite package that fixes one security issue is now
available for Red Hat Enterprise Linux 3 and 4.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

The 4Suite package contains XML-related tools and libraries for
Python, including 4DOM, 4XSLT, 4XPath, 4RDF, and 4XPointer.

A buffer over-read flaw was found in the way 4Suite's XML parser
handles malformed UTF-8 sequences when processing XML files. A
specially crafted XML file could cause applications using the 4Suite
library to crash while parsing the file. (CVE-2009-3720)

Note: In Red Hat Enterprise Linux 3, this flaw only affects a
non-default configuration of the 4Suite package: configurations where
the beta version of the cDomlette module is enabled.

All 4Suite users should upgrade to this updated package, which
contains a backported patch to correct this issue. After installing
the updated package, applications using the 4Suite XML-related tools
and libraries must be restarted for the update to take effect.

See also :

https://www.redhat.com/security/data/cve/CVE-2009-3720.html
http://rhn.redhat.com/errata/RHSA-2009-1572.html

Solution :

Update the affected 4Suite package.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Red Hat Local Security Checks

Nessus Plugin ID: 42456 ()

Bugtraq ID: 36097

CVE ID: CVE-2009-3720