MS09-044: Vulnerabilities in Remote Desktop Connection Could Allow Remote Code Execution (970927)

This script is Copyright (C) 2009-2015 Tenable Network Security, Inc.


Synopsis :

It is possible to execute arbitrary code on the remote host.

Description :

The remote host contains a version of the Remote Desktop client with
several vulnerabilities that may allow an attacker to execute
arbirtary code on the remote host.

To exploit these vulnerabilities, an attacker would need to lure a
user of the remote host to connect to a rogue RDP server.

See also :

http://technet.microsoft.com/en-us/security/bulletin/MS09-044

Solution :

Microsoft has released a set of patches for Windows 2000, XP, 2003,
Vista and Server 2008.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 40565 ()

Bugtraq ID: 35971
35973

CVE ID: CVE-2009-1133
CVE-2009-1929