MS09-040: Vulnerability in Message Queuing Could Allow Elevation of Privilege (971032)

This script is Copyright (C) 2009-2017 Tenable Network Security, Inc.


Synopsis :

Users can elevate their privileges on the remote host.

Description :

The remote version of Windows is affected by a vulnerability in the
Microsoft Message Queuing Service (MSMQ).

An attacker with valid login credentials may exploit this flaw to
execute arbitrary code on the remote host with the SYSTEM privileges
and therefore elevate his privileges.

See also :

https://technet.microsoft.com/library/security/MS09-040

Solution :

Microsoft has released a set of patches for Windows 2000, XP, 2003 and
Vista.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.4
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 40559 ()

Bugtraq ID: 35969

CVE ID: CVE-2009-1922

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now