Mac OS X < 10.5.8 Multiple Vulnerabilities

This script is Copyright (C) 2009-2013 Tenable Network Security, Inc.


Synopsis :

The remote host is missing a Mac OS X update that fixes various
security issues.

Description :

The remote host is running a version of Mac OS X 10.5 that is older
than version 10.5.8.

Mac OS X 10.5.8 contains security fixes for the following products :

- bzip2
- CFNetwork
- ColorSync
- CoreTypes
- Dock
- Image RAW
- ImageIO
- Kernel
- launchd
- Login Window
- MobileMe
- Networking
- XQuery

See also :

http://support.apple.com/kb/HT3757
http://lists.apple.com/archives/security-announce/2009/Aug/msg00001.html

Solution :

Upgrade to Mac OS X 10.5.8 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true