Ubuntu 6.06 LTS / 8.04 LTS / 8.10 / 9.04 : gst-plugins-good0.10 vulnerability (USN-789-1)

Ubuntu Security Notice (C) 2009-2013 Canonical, Inc. / NASL script (C) 2009-2013 Tenable Network Security, Inc.

Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Tielei Wang discovered that GStreamer Good Plugins did not correctly
handle malformed PNG image files. If a user were tricked into opening
a crafted PNG image file with a GStreamer application, an attacker
could cause a denial of service via application crash, or possibly
execute arbitrary code with the privileges of the user invoking the

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.8

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 39491 ()

Bugtraq ID:

CVE ID: CVE-2009-1932