Ubuntu 6.06 LTS / 7.10 / 8.04 LTS : imlib2 vulnerability (USN-697-1)

Ubuntu Security Notice (C) 2008-2013 Canonical, Inc. / NASL script (C) 2009-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

It was discovered that Imlib2 did not correctly handle certain
malformed XPM and PNG images. If a user were tricked into opening a
specially crafted image with an application that uses Imlib2, an
attacker could cause a denial of service and possibly execute
arbitrary code with the user's privileges.

Solution :

Update the affected libimlib2 and / or libimlib2-dev packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 36815 ()

Bugtraq ID:

CVE ID: CVE-2008-2426