Ubuntu 6.06 LTS / 7.10 / 8.04 LTS / 8.10 : avahi vulnerabilities (USN-696-1)

Ubuntu Security Notice (C) 2008-2014 Canonical, Inc. / NASL script (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Emanuele Aina discovered that Avahi did not properly validate its
input when processing data over D-Bus. A local attacker could send an
empty TXT message via D-Bus and cause a denial of service (failed
assertion). This issue only affected Ubuntu 6.06 LTS. (CVE-2007-3372)

Hugo Dias discovered that Avahi did not properly verify its input when
processing mDNS packets. A remote attacker could send a crafted mDNS
packet and cause a denial of service (assertion failure).
(CVE-2008-5081).

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
Public Exploit Available : true

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 36657 ()

Bugtraq ID:

CVE ID: CVE-2007-3372
CVE-2008-5081