Ubuntu 6.06 LTS / 7.10 / 8.04 LTS / 8.10 : imlib2 vulnerability (USN-683-1)

Ubuntu Security Notice (C) 2008-2013 Canonical, Inc. / NASL script (C) 2009-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

It was discovered that Imlib2 did not correctly handle certain
malformed XPM images. If a user were tricked into opening a specially
crafted image with an application that uses Imlib2, an attacker could
cause a denial of service and possibly execute arbitrary code with the
user's privileges.

Solution :

Update the affected libimlib2 and / or libimlib2-dev packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 36374 ()

Bugtraq ID:

CVE ID: CVE-2008-5187