GLSA-200903-03 : Audacity: User-assisted execution of arbitrary code

This script is Copyright (C) 2009-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200903-03
(Audacity: User-assisted execution of arbitrary code)

Houssamix discovered a boundary error in the
String_parse::get_nonspace_quoted() function in

Impact :

A remote attacker could entice a user into importing a specially
crafted *.gro file, resulting in the execution of arbitrary code or a
Denial of Service.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All Audacity users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-sound/audacity-1.3.6'

Risk factor :

High / CVSS Base Score : 9.3

Family: Gentoo Local Security Checks

Nessus Plugin ID: 35793 (gentoo_GLSA-200903-03.nasl)

Bugtraq ID:

CVE ID: CVE-2009-0490