GLSA-200903-02 : ZNC: Privilege escalation

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200903-02
(ZNC: Privilege escalation)

cnu discovered multiple CRLF injection vulnerabilities in ZNC's
webadmin module.

Impact :

A remote authenticated attacker could modify the znc.conf configuration
file and gain privileges via newline characters in e.g. the QuitMessage
field, and possibly execute arbitrary code.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200903-02.xml

Solution :

All ZNC users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-irc/znc-0.066'

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 35792 (gentoo_GLSA-200903-02.nasl)

Bugtraq ID:

CVE ID: CVE-2009-0759