GLSA-200807-14 : Linux Audit: Buffer overflow

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200807-14
(Linux Audit: Buffer overflow)

A stack-based buffer overflow has been reported in the
audit_log_user_command() function in the file lib/audit_logging.c when
processing overly long arguments.

Impact :

A local attacker could execute a specially crafted command on the host
running Linux Audit, possibly resulting in the execution of arbitrary
code with the privileges of the user running Linux Audit.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200807-14.xml

Solution :

All Linux Audit users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=sys-process/audit-1.7.3'

Risk factor :

Medium / CVSS Base Score : 4.1
(CVSS2#AV:L/AC:M/Au:S/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 33780 (gentoo_GLSA-200807-14.nasl)

Bugtraq ID:

CVE ID: CVE-2008-1628