GLSA-200803-27 : MoinMoin: Multiple vulnerabilities

This script is Copyright (C) 2008-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200803-27
(MoinMoin: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered:
A vulnerability exists in the file because the
_macro_Getval function does not properly enforce ACLs
A directory traversal vulnerability exists in the userform action
A Cross-Site Scripting vulnerability exists in the login action
Multiple Cross-Site Scripting vulnerabilities exist in the file
action/ when using the message, pagename, and target
filenames (CVE-2008-0781).
Multiple Cross-Site Scripting vulnerabilities exist in
formatter/ (aka the gui editor formatter) which can be
exploited via a page name or destination page name, which trigger an
injection in the file (CVE-2008-1098).

Impact :

These vulnerabilities can be exploited to allow remote attackers to
inject arbitrary web script or HTML, overwrite arbitrary files, or read
protected pages.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All MoinMoin users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/moinmoin-1.6.1'

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 31614 (gentoo_GLSA-200803-27.nasl)

Bugtraq ID: 28177

CVE ID: CVE-2008-0780