SAPlpd < 6.29 Multiple Vulnerabilities

This script is Copyright (C) 2008-2012 Tenable Network Security, Inc.


Synopsis :

The remote print service is affected by multiple vulnerabilities.

Description :

SAPlpd, a component of SAP GUI, is running on the remote host.

According to its version number, the installation of SAPlpd running on
the remote host is affected by several denial of service and buffer
overflow vulnerabilities. An unauthenticated, remote attacker can
leverage these issues to crash the affected service or to execute
arbitrary code on the affected host subject to the privileges under
which it operates.

See also :

http://aluigi.altervista.org/adv/saplpdz-adv.txt
http://archives.neohapsis.com/archives/bugtraq/2008-02/0030.html
http://archives.neohapsis.com/archives/bugtraq/2008-02/0038.html

Solution :

Upgrade to SAPlpd version 6.29 or later by updating to SAP GUI for
Windows version 7.10 Patchlevel 6 / 6.30 Patchlevel 30 / 6.20
Patchlevel 72 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 31121 ()

Bugtraq ID: 27613

CVE ID: CVE-2008-0620
CVE-2008-0621